Academy Dashboard Forum Studio DAWs Pro Tools Pro Tools 2019 is available


  • This topic has 10 replies, 4 voices, and was last updated 5 years ago by Paul Motion.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #62018
    Paul Motion

      Looking at my Avid Link the update for Pro Tools 2019 is now available! Huzzah!!! If anyone downloads and installs it, if you have a minute, please post your thoughts and any issues here.


      David Michael

        Personally, I am having a terrible time with this update. I am on a Mac. I already had Mojave installed before I migrated to Pro Tools (I didn't see their warnings before doing so sadly).

        I have now lost track of the number of times I have had to force quit the application as it has run out of CPU and will not respond. Last time I ran it (about 15 minutes ago), the system told me that Pro Tools was not optimised for my system and would need to be updated!! Like, say that again! It fell over after about 20 seconds of playing the session I loaded. CPU fans go crazy running the application (mind you it did that before the update - so probably my system) and it did /does that simply playing the audio with nothing added.

        I tried some stuff like dropping the sample rate back down and increasing the memory and that seemed to work but obviously not really.

        I do not have the luxury of having a dedicated system for music so it is running on a 'home computer' for want of a better phrase. Having said that it is running a 4Gz Quad Core i7 with turbo boost to 4.2Gz and hyper-threading so it has 8 virtual cores (at those speeds). It has 32Gb of main memory and a 1Tb SSD. The system is not slow.

        I have tried cutting down on the running applications like browsers etc to no avail.

        Pro Tools worked better before this update. For me, it is essentially unusable right now.

        Shame that because a) I really like the application and b) I am paying for it.

        If anyone has any ideas, throw them my way.

        Thanks, David

        Scott Peets

          That's so frustrating David. Did you reset your buffer setting in the playback engine to 1024? That may help.

          Arthur Bod

            I upgraded from 12.7 to 2019.5 without getting properly prepared. I wanted to be able to work with OSX 10.14.3 which I also upgraded to before thinking.

            Took me a full day of pulling my hair out trying to get things to work. After installation, I could not add tracks or insert or remove plugins, regardless of New or Old sessions. Here is what worked for me. By the way, my rig is a 2016 MacBook Pro 2.7 - i7 with 16 gig of ram.

            I deleted all of the preference, workspace and wavecache files as well as database files. Avid explains this fairly well, though it shows two files to delete that I couldn't find. Anyway, thereafter I deleted the installation of ProTools 2019.5 by moving the app to the trash bin. Did this twice to find it still didn't work.

            So I repeated the process again, but this time I also deleted every folder with the name AVID or PROTOOLS. Backed up the PlugIns first by the way. After this delete process I reinstalled PT 2019.5 for like the 4th time and it worked. Seems it was the deletion of the FOLDERS left behind that made the difference.

            I swear I'm never updating anything again! Anyway, hope this helps anyone in the same boat.


            Paul Motion

              Thanks for weighing in with your issues folks. I took the plunge after a bit of research and so far have experienced a couple of minor issues but certainly nothing as bad how you guys seem to have it. So sorry you’ve experiencing these things.
              I’ve had the CPU over run warning a couple of times, even when my usage is no more than 40 or 50%.
              Saving and quitting has given me the beach ball of death a few times as well.

              I haven’t noticed any discernible improvement to resource usage to be honest.

              I updated from PT2018 through the Avid Link software so maybe that helped. I’m also running EUCON, connected to an ancient iPad running the Control app which seems to work quite nicely.

              No plugin compat problems...... yet.

              I’m on a Macbook pro 13” 2017,(?).... one of the new dark grey models, i7 quad core 2.xGhz with 16GB ram. So a decent home/work laptop.

              I haven’t found much on known issues from Avid yet. Would be good if anyone else spots anything to post here as well.

              • This reply was modified 5 years ago by Paul Motion.
              David Michael

                Interesting. I am just in from work so I'll see if I can get anywhere. I've updated the samples to 1024, although it was either that or 512 at the point I updated. As clicking the play button did not respond at all, I dropped the samples.

                I ran Pro Tools to change the sample rate with a project that had only midi in it and it told me that Falcon was not authorised!! That's not what iLok was saying, unless there was a glitch as its on the cloud - funny, so is my Pro Tools subscription.

                I'll see what happens with the sample change.

                And then I'll look to doing any deletes of the folders. Arthur Bod, did you uninstall Pro Tools before deleting the folders. I assume from what you said that you got delete instructions from Avid?

                Paul Motion I tried running EUCON. Pro Tools fell over!



                • This reply was modified 5 years ago by David Michael.
                David Michael

                  Just a quick update; the sample rate change appeared to use a little less CPU, until about a minute or so in when it suddenly stuttered to a halt and I had to force quit again.

                  Arthur Bod

                    David, I didn't get the folder delete instructions from Avid. I just figured after the previous attempts that maybe there was something in one of those that was causing the conflict. I trashed the app first before deleting the folders. Actually, I probably did things in this order: delete the files listed by Avid, trash the app and then the folders.

                    All of this so I can use the import audio function which doesn't work with Mohave and < 2019.5. Well, so far anyway.

                    David Michael

                      Arthur, I tried that approach anyway. Backed up the plugins folder. Uninstalled the app, Avid link etc., then deleted the files and folders and wavecache files. I didn't delete the preference files (I forgot). Re-downloaded and reinstalled and so far it has not failed. It is still hitting the computer system CPU hard causing the fans to go into overdrive but it wasn't falling over (not yet at least). I am keeping an eye on Pro Tools system usage dialog and so far the track I was mixing was only hitting around 50-55%. Falcon decided to behave too.

                      I have yet to discover what if there is anything I can do to alleviate the fans going crazy but, like I said, this is my main computer so it could be that.

                      Thanks for the feedback so far.

                      Arthur Bod

                        David . . . I need to pay attention to the fans tonight. I seem to be running smoothly, but I'm way early in my learning curve so who knows. And I have not loaded up a session with plugins yet. Still laying down tracks. I'll let you know if/when I run into issues. I'm sure there are a few lurking about!

                        Good luck!

                        Paul Motion

                          Updating my laptop config:
                          Mojave 10.14.4
                          macbook pro, 13" 2016.
                          3.3GHz i7
                          16GB RAM
                          Intel GPU
                          Thanks work for my beefy laptop... no.. I could never afford a mac like this! 🙂

                          Import audio worked fine for me. I had Rewire running with Reason no problem and just launched Falcon no issues.. it automatically refreshed my subscription through the cloud iLok.
                          Not sure what I've done but so far I've been pretty lucky and haven't had any major issues. This is a work laptop so I have all the usual work rubbish installed like Office etc.... Hopefully the good vibes continue!
                          Bearing in mind I don't track and don't have any I/O outboard gear so I don't have that joy to deal with.....

                        Viewing 11 posts - 1 through 11 (of 11 total)
                        • You must be logged in to reply to this topic.