Academy Dashboard Forum Studio Gear Talk HELP please! SSL Nucleus and Pro Tools 'communication' issue

  • This topic has 8 replies, 4 voices, and was last updated 7 years ago by mick335.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #8952

      Hi. I’m kinda cheating here, and maybe even breaking the rules, but please bear with me on this, as I really am desperate! (and I have already tried the Avid forums, by the way).

      I have a software or hardware (or just pure gremlins!) problem that none of the experts (Avid or Solid State Logic) can help me with and thought I’d raise it her , just in case any of you great people have any thoughts?

      In summary, I am using Pro Tools 12.5 (though this also happened in 12.4, and even 11.3) on Windows 7 Professional, on an HP Z600 workstation (dual Xeon 2.8GHz; 32GBDRAM, Enterprise-class SSDs).

      All works well, but my DAW controller is an SSL Nucleus. The problem is. . . after a while (could be 5 minutes, could be 3 hours) the Nucleus drops off, so that it won’t transmit data – it will only receive (in other words, if I press play on the Nucelus, it won’t respond, but if I press the space bar (play) on my computer keyboard, the Nucleus Play button lights up).

      For reference, the Nucleus transmits MIDI data over Ethernet, using some software called ipMIDI. ipMIDI opens up 6 ports (the Nucleus uses one port for each 8 channels, so as it is a 16 channel controller, it needs to MIDI channels, plus it operates up to three DAWS (independently) so hence the 6 MIDI ports).

      I have optimized Windows as suggested by Avid. I have also optimized the Network settings / address per SSL’s instructions, and this issue still happens. I’ve done a fresh install of Windows 7 4 times now (each time on a new drive)

      I have also tried a different 1Gbit Ethernet card, as well as changed cables. I also have wireless disabled (in fact, I even removed the wireless card).

      Does anyone have any thoughts about this? Why this is an intermittent issue? I’ve tried running the Nucleus with Studio One, and it seems to run fine, so that makes it worse, in that it appears to be a PT related issue - yet it USED to work with previous versions of PT! Driving me crazy, so would really appreciate it if something obvious jumps out to someone 

      Thanks! Mick.

      (PS. Anyone want to buy a Nucleus – as long as you don’t use Windows, or Pro Tools? )

      John Gleason

        Mick, since you've tried everything else you might want to go into the Windows Control Panel to the Device Manager and select your ethernet Network Adapter. Check the power saving settings and uncheck the box that allows your computer to power-down the adapter. It is possible that Windows doesn't sense that the ethernet port is in use by the Nucleus and doesn't wake the port. Any settings you can find to keep the port active all the time might solve your problem. Good luck!


        John Gleason

          Mick, try my above suggestion first. If no joy, here are 2 suggestions I found on the internet: If your computer also has a wireless card, turn it on and leave it on (this sometimes keeps the wired network adapter awake also). Or buy a cheap-o network hub and plug it in between your computer and the Nucleus. Leave the hub powered on and it may keep the network adapter awake. There were also reports of advanced settings that were in the Device Manager with some older network adapters where you could set a 'keep awake' flag, but newer postings suggest this is no longer available (I didn't find it in my system). 'Hope this helps!



            Hi John. Thank you for taking the time to think about this. I've actually set all the network, USB devices, etc, to prevent power off, but interesting that you suggest these other ideas...I'll take any suggestions right now, and will certainly try them!

            Thanks....will be reporting back!

            Cheers, Mick.

            Loren Knight

              What John suggests is what I'd suggest. As a side note USB has a similar power options property that should be turned off for USB interfaces too.


                Hi. Thanks again for this. I have actually disabled the 'sleep' option on all of my USB devices. I also tried John's suggestion, but it is still happening. The annoying thing is, it might happen after 2 minutes, or it could work for 3 hours, but at some point, I always lose the MIDI (over Ethernet) connection.

                That does point to some conflict, at some point cutting in and interrupting or closing the Ethernet connection.

                I've disabled wireless; I've enabled it. I have even removed the Wi-Fi card. I've replaced my network card with another Intel dual port card. Then I've disabled the motherboard Ethernet.

                It just occurred to me that maybe there is something relevant in the BIOS? I guess I should look!

                Thanks again for taking the time to think about this VERY debilitating (creatively-wise!) problem.

                Regards, Mick.

                John Gleason


                  I think connecting your computer to an ethernet network hub (which you keep powered-on 24/7) and then from the hub to the Nucleus is worth trying (although it may cost you some money -- maybe you can borrow someone's just to test?). The concept is that the hub will keep your ethernet connections refreshed and awake. If the problem is in the Nucleus driver software and SSL can't support you then you might be at the end of the line (major bummer) and some real noise directed at Avid and SSL may be your only hope (I can't believe that you are the only user to have this problem).

                  Good luck ...


                  Andrew Mckenzie

                    Hiya Mick, I'm not familiar with Pro Tools or the Nucleus but coming from a geek background :-).... If you were saying that a different DAW works OK and that there is no issue with communications then I would probably point the finger at software rather than hardware.

                    If the system works for one DAW and not another it suggests to me that the hardware is functional (otherwise it wouldn't work for any DAW). Would it be worth contacting Avid to see if there is any compatibility issues with using the latest version of Pro Tools in conjunction with your Nucleus?

                    Hope you get it sorted.



                      Thanks Andrew - and I am sure you are correct. This is most likely either the DAW, or possibly the MIDI over ethernet software.

                      Unfortunately, every time (I mean every time - four that I can think of!) I contact Avid about an issue, they are never able to resolve it. This is no different; I get the "speak to Microsoft / SSL" feedback.

                      I'm going to give Avid one more chance, then I guess I have to choose whether to trade my Workstation for a Mac (assuming that is a resolution) or just start using another DAW 🙁

                      Thanks again. Mick.

                    Viewing 9 posts - 1 through 9 (of 9 total)
                    • You must be logged in to reply to this topic.